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Abstract: The rapid development of Internet of Things (IoT) technology has significantly transformed conventional household 

systems into intelligent environments. Smart home automation enables users to remotely monitor and control electrical appliances 

through internet-enabled devices. This paper presents the design and development of an IoT-based home automation system using 

the ESP8266 microcontroller and Blynk cloud platform. The proposed system allows users to operate household appliances such as 

lights, fans, and other electrical devices using a smartphone application connected through Wi-Fi. The system integrates hardware 

components including ESP8266, relay modules, and a wireless network with a user-friendly mobile interface. The developed system 

is economical, easy to install, and suitable for real-time monitoring and control. Experimental results indicate that the system 

performs efficiently with reliable communication and minimal delay. The proposed model offers a practical solution for modern 

smart homes and can be further enhanced by integrating sensors and security features. 
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I. INTRODUCTION 

In recent years, the Internet of Things (IoT) has become one of the most influential technologies in the field of automation and 

intelligent systems. IoT refers to the interconnection of physical devices through the internet, enabling them to communicate and 

exchange information. This technology has been widely applied in several sectors including healthcare, transportation, agriculture, 

and smart homes. 

Home automation is a key application of IoT where electrical appliances and devices can be controlled automatically or remotely. 

Smart home technology allows users to manage household systems such as lighting, fans, air conditioning, and security devices 

through smartphones or computers. This not only enhances user comfort but also improves energy efficiency and safety. 

Traditional home automation systems were expensive and required complicated wiring and installation processes. Such systems 

were mainly limited to large commercial buildings or luxury homes. However, the development of low-cost microcontrollers and 

wireless communication technologies has made home automation more affordable and accessible. 

The ESP8266 microcontroller has gained popularity in IoT applications due to its built-in Wi-Fi capability, low cost, and compact 

design. By integrating ESP8266 with a cloud platform such as Blynk, users can easily control appliances through a smartphone 

interface without complex server configuration. 

This research focuses on the design and implementation of a low-cost IoT-based smart home automation system that enables 
remote control of electrical appliances through a mobile application. 

2. LITERATURE REVIEW 

The rapid advancement of Internet of Things (IoT) technology has led to the development of numerous smart home automation 

systems that aim to improve convenience, security, and energy efficiency in residential environments. Early home automation 

systems were primarily based on wired communication networks, which required extensive cabling and high installation costs. With 

the evolution of wireless communication technologies, more flexible and cost-effective solutions have emerged. 

Gomathy (2022) [1] presented an IoT-based home automation system integrating communication technologies such as Bluetooth, 

Zigbee, and cloud platforms. In this approach, Bluetooth modules allow users to control appliances through smartphones using 

Arduino-based boards, while Zigbee provides reliable and low-power communication between devices. Cloud computing enables 

remote monitoring and device management by storing data and providing advanced automation features. The study also highlights 

the importance of security mechanisms, including Near Field Communication (NFC), to ensure privacy and protect user data. 

Furthermore, the research emphasizes the rapid growth of the IoT market and its significant contribution to energy savings, 

automation, and improved home security. 

Kadiyan et al. (2023) [2] investigated the design and implementation of an IoT-based smart home automation system that focuses 

on remote monitoring, energy management, security, and user convenience. The system integrates sensors, actuators, and a central 

control unit to enable automated operation of household devices. The authors also discussed future prospects of smart home systems 

with the integration of artificial intelligence and advanced connectivity technologies. Additionally, the study emphasizes the need 

to address privacy and security concerns to ensure safe data transmission and user trust. The integration of smart home systems with 
smart grids and smart cities is also highlighted as an important step toward sustainable living environments. 

B. N. et al. (2023) [3] examined the implementation of IoT-based smart home systems that enable remote monitoring and control 

of appliances such as lights, fans, doors, refrigerators, and washing machines. The system utilizes microcontrollers such as Arduino 

Uno connected to the internet via ESP8266 Wi-Fi modules. This configuration allows users to manage household devices remotely 

using internet connectivity. The study also discusses various wireless communication technologies used in home automation, 

including Bluetooth, Zigbee, GSM, and Wi-Fi, and emphasizes the importance of integrating these technologies to create a seamless 

and user-friendly automation system. The research further highlights the economic and safety benefits of smart home technologies.  
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Stolojescu et al. (2021) [4] proposed a home automation framework called qToggle, which interconnects sensors, actuators, and 

other devices using a flexible Application Programming Interface (API). The qToggle system provides a unified communication 

platform that simplifies interaction among different devices in a smart home environment. The system primarily uses hardware 

based on ESP8266/ESP8285 microcontrollers and Raspberry Pi boards. A dedicated smartphone application allows users to 

remotely monitor and control home appliances and sensors. The study demonstrates that the qToggle platform offers flexibility, 
scalability, and ease of customization for various automation applications. 

Syifaul et al. (2021) [5] developed an IoT-based smart street lighting system using ESP8266 modules configured in a wireless 

mesh network. In this system, the ESP8266 microcontroller generates Pulse Width Modulation (PWM) signals to control light 

intensity based on sensor inputs. The system is accessible through a web-based interface, enabling remote monitoring and control. 

The research demonstrates the effectiveness of wireless mesh networking in IoT applications and compares the system with existing 
smart lighting projects in terms of performance and complexity. 

Sen et al. (2015) [6] designed a voice-controlled home automation system that operates on Android devices. The system consists 

of an Arduino Uno microcontroller interfaced with a Bluetooth module to establish communication between the smartphone and 

the control circuit. An Android application converts voice commands into text, which is transmitted wirelessly to the 

microcontroller. The controller processes the command and activates the corresponding appliance. Although this approach improves 
user convenience, the communication range is limited due to the use of Bluetooth technology. 

Singh et al. (2015) [7] proposed a GSM-based home automation system that enables users to control appliances through SMS 

commands. In this system, a GSM module is interfaced with a microcontroller to receive user commands and send notifications. 

The microcontroller processes incoming SMS messages and activates appliances through a switching module. While GSM-based 

systems provide wide network coverage, they require additional hardware and depend on cellular network availability.  

Kodali et al. (2016) [8] incorporated an internet-based security feature into a home automation system using a TI CC3200 

Launchpad board as the main controller. The system integrates a Wi-Fi module for communication, relay modules for appliance 

control, and a Passive Infrared (PIR) motion sensor for intrusion detection. When motion is detected, the system sends an alert to 

the user's mobile device, allowing the user to determine whether the detected activity is authorized. If the intrusion is unknown, an 

alarm is triggered. Although the system primarily focuses on security, the control mechanism can be extended for broader home 
automation applications. 

Despite the significant progress in IoT-based home automation technologies, several challenges still remain. Many existing 

systems focus on specific features such as security monitoring, voice control, or remote switching rather than providing a 

comprehensive and integrated automation solution. In addition, some solutions rely on expensive proprietary hardware or require 
professional installation, making them less suitable for everyday household applications. 

Therefore, there is a need for a low-cost, flexible, and easy-to-implement smart home automation system that can integrate with 

existing appliances while offering reliable remote control and improved user convenience. The system proposed in this study 

addresses these challenges by utilizing the ESP8266 microcontroller and Blynk cloud platform to develop a scalable, affordable, 

and user-friendly IoT-based home automation solution. 

3. OBJECTIVES 

The aim & objective of this work is to develop a cost effective IoT based home automation system to remotely control and 
monitor any household appliance connected to it by using a microcontroller and IoT infrastructure. 

 To develop a cost-effective and user-friendly IoT-based home automation system using the ESP8266 and Blynk Cloud. 

 To enable easy installation, remote monitoring, and control of household appliances without requiring professional 

expertise. 

4. COMPARATIVE STUDY 

The following Table 1 gives a comparison between the different Home Automation System with respect to their speed, cost, and 
availability. 

Table 1 Comparison of Different HAS Models 

System Cost Speed Availability 

GSM using Microcontroller High Slow High 

Voice Recognition using Kinect Sensor Low Fast Low 

Bluetooth using Arduino Low Fast Low 

IoT Low Fast High 

Low-cost, open source hardware components, such as Arduino and Raspberry Pi microcontroller unit (MCU) boards, and a 

combination of sensors have been very used in the home automation domain. Arduino is highly flexible, open source, not expensive, 

and easy to program [14]. In addition, the existence of a large and active community of users is a great plus. However, Arduino is 

not designed to handle the large complexity that comes with advanced projects.  

For more advanced and real-time projects, Raspberry Pi is a better option. Raspberry Pi is an exciting technological development 
that is much cheaper than any desktop computer or mobile device [15]. 

ESP8266 chips are low-price Wi-Fi modules that are perfectly suited for projects in the IoT field. ESP8266 is a single core 

processor that runs at 80 MHz. ESP8266 chips were used for home automations-related projects. The ESP8266 module is one 

solution to implement IoT. Moreover, the ESP8266 is a low-cost Wi-Fi technology compared to other IoT technologies (e.g., Zigbee, 

LoRa, Wi-Fi shield for Arduino, etc.) as shown in Table 2. [5] 
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Table 2 Cost Comparison of Existing IoT Module 

IoT Devices Price 

ESP8266 ₹328/- 

Zigbee ₹1850/- 

LoRa ₹1450/- 

Wi-Fi Shield for Arduino ₹945/- 

Huzzah WiFi Shield by Adafruit ₹1588/- 

Ethernet Shield for Arduino ₹610/- 

Raspberry Pi Wi-FI Module ₹1299/- 

5. SOFTWARE IMPLEMENTATION 

5.1. Arduino IDE 

The Arduino IDE is an open-source software, which is used to write and upload code to the Arduino boards. The IDE application 

is suitable for different operating systems such as Windows, Mac OS X, and Linux. It supports the programming languages C and 

C++. Here, IDE stands for Integrated Development Environment. 

The ESP8266 is programmed using the Arduino Integrated Development Environment. The program handles Wi-Fi connectivity, 
communication with the Blynk server, and control logic. 

5.2. Blynk Mobile Application 

Blynk provides a graphical interface where users can create control buttons, switches, and indicators to operate appliances 

remotely. 

It is also possible to share a project with friends and even customers so that they can access the connected devices but not be able 

to modify the project. Imagine a scenario where you build a smartphone application where you can control lights, window blinds 

and room temperature from your phone. You can share the project with other family members so that they can also access the 
functionality. 

6. CIRCUIT DIAGRAM AND CONNECTIONS 

 

Fig.1 Circuit diagram of Home Automation Sytem 

This is the complete circuit diagram for this home automation project. In this circuit, the GPIO pins D1, D2, D5 & D6 are 

connected to relay inputs to control the 4 relays and the GPIO pins D7, D4, D3 & RX connected with push buttons to ground for 

manual operation. The phase of the AC Supply is connected to Common pin of each relay and neutral of AC Supply is connected 

to one terminal of loads. The Normal opened contact pin is connected to another terminals of loads. I have used a 5V mobile charger 

to supply the DC power to ESP module and Relay. The D3 pin should not be connected with GND during the booting process of 

NodeMCU. 

The selection of these specific GPIO pins is influenced by several factors related to the capabilities and limitations of the 

ESP8266's hardware design, the boot process requirements, and the specific roles of these pins. GPIOs D1, D2, D5, and D6 are 

suited for relay control because they do not interfere with the boot process and are capable of driving loads, while D7, D4, D3, and 

RX are available and reliable for manual push-button inputs without interfering with system operations. 

7. PROGRAMMING (CODING AND UPLOADING) 

1. Install Arduino IDE: Download and install the Arduino IDE from the official Arduino website. 

2. Install ESP8266 Board Support: 

 Open Arduino IDE. Go to File > Preferences. 

 In the Additional Board Manager URLs field, paste the following URL: 

 http://arduino.esp8266.com/stable/package_esp8266com_index.json. Click OK. 
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1. Go to Tools > Board > Boards Manager. 

2. Search for "ESP8266" and install the ESP8266 by ESP8266 Community. 

3. Select ESP8266 Board: Go to Tools > Board and select NodeMCU 1.0 (ESP-12E Module) or the appropriate version of 
ESP8266 that you are using. 

4. Install Required Libraries: 

 Go to Sketch > Include Library > Manage Libraries. 

 Search for and install the Blynk library by Blynk Inc. 

 You may also need to install the ESP8266WiFi library, which usually comes pre-installed with the ESP8266 board 

package. 

5. Writing the Program for Home Automation: 

 Write the program to control 4 relays through the ESP8266 using the Blynk app by include all the libraries.  

 Now, copy and paste BLYNK_AUTH_TOKEN, BLYNK_TEMPLATE_ID & BLYNK_TEMPLATE_NAME to the 
program. 

 Next, enter your correct WIFI name and password i.e. SSID & Password of your Wi-Fi or after uploading the code, you 

have to update the Wi-Fi credentials through OTA. 

6. Uploading the Program to ESP8266: 

 Connect ESP8266 to your PC: Use a micro-USB cable to connect the ESP8266 board (NodeMCU) to your computer. 

 Select the Correct Port: Go to Tools > Port and select the port your ESP8266 is connected to (e.g., COM3). 

 Compile and Upload Click the Upload button (right arrow) in the Arduino IDE to compile and upload the code to the 
ESP8266. 

 During uploading the code, the blue LED of ESP8266 will goes ON until upload finishes. 

8. MOBILE BLYNK APPLICATION CONFIGURATION 

Step 1: Install Blynk IoT App to Configure Mobile Dashboard: 

 Install the Blynk IoT app from Google Play Store or App Store. Then log in. 

 Go to Developer Mode. 

 Tap on the template that you have already made. 

 Now go to the Widget box (on the right) to add widgets. 

Step 2: Add Widgets in Blynk IoT App: 

 Add 4 Button widgets from Widget Box. 

 Go to Button widget settings. 

 Enter the name, select Datastream & Mode (select Switch). Then exit. 

 After setting on all the Buttons tap on exit. 

9. FUNCTIONAL FLOWCHART OF THE SYSTEM 

The flowchart of the smart home automation system describes the sequence of operations performed by the system. The sequence 
of steps that flowchart represents are as follows, 

 The process begins with the system startup. 

 Check if the ESP8266 module is connected to Blynk App via Wi-Fi network. If No, the system needs to establish a 

connection. If Yes, proceed to the next step. 

 Ensure that the smartphone is connected to the internet; otherwise, Blynk Application will not work. If Yes, continue to 
the next step. 

 Use the Blynk app on the smartphone to send a command to turn the appliance ON or OFF. 

 After receiving the command from the app, the ESP8266 module initializes the necessary action. 

 The relay switch is triggered based on the received command (either turning the appliance ON or OFF). 

 The connected home appliance is either turned ON or OFF depending on the command issued. 
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Fig.2 Functional Flowchart of the System 

10. RESULTS AND DISCUSSION 

The proposed smart home automation system was successfully implemented and tested in a laboratory environment. The 
appliances connected to the relay module were controlled through the Blynk mobile application. 

The system demonstrated the following advantages: 

 Low implementation cost 

 Easy installation 

 Reliable wireless communication 

 Real-time remote control 

 User-friendly interface 

The response time of the system was minimal and depended mainly on internet connectivity. The results confirm that the system 

provides efficient and stable operation for remote appliance control. 

11. CONCLUSION 

This paper presented the design and implementation of an IoT-based smart home automation system using ESP8266 

microcontroller and Blynk cloud platform. The system allows users to control electrical appliances remotely through a smartphone 

application. 

The proposed system is cost-effective, easy to implement, and suitable for modern residential environments. By integrating 
wireless communication and cloud services, the system provides convenient and reliable automation. 

Future enhancements may include integration of environmental sensors, voice-based control, and advanced security systems to 

further improve smart home functionality. 
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